Добро пожаловать, Гость
Логин: Пароль: Запомнить меня

ТЕМА: Начисление по среднему отпуск

Начисление по среднему отпуск 2 нед. 5 дн. назад #1

  • Anat
  • Anat аватар
  • Не в сети
  • Захожу иногда
  • Сообщений: 52
  • Спасибо получено: 22
  • Репутация: 1
Создан документ начисление по среднему отпуск рассчитан проведен. В справочнике сотрудники закладка информация таблица отпуска создается запись. Документ помечаем на удаление в справочнике таблица отпуска запись остается. Снимаем пометку удаление в документе меняем фамилию и дни рассчитываем проводим запись в справочнике сотрудники отпуска теперь у двоих сотрудников. Помечаем на удаление. Запись по прежнему у двоих сотрудников. Так должно быть ?
Администратор запретил публиковать записи гостям.

Начисление по среднему отпуск 2 нед. 4 дн. назад #2

  • Ольга Николаевна
  • Ольга Николаевна аватар
  • Не в сети
  • Методист центра разработки
  • Сообщений: 1340
  • Спасибо получено: 1502
  • Репутация: 154
Проверено на релизе 3.0.92.3.
При установке пометки удаления на документ "начисление по среднему" с помощником "Расчет по среднему (отпуск, командировка)" запись об отпуске в справочнике "сотрудники" удаляется.
Акулиничева Ольга Николаевна
фирма "Камин"
Администратор запретил публиковать записи гостям.
Спасибо сказали: Андрей Ланьшин, Anat

Начисление по среднему отпуск 2 нед. 4 дн. назад #3

  • Anat
  • Anat аватар
  • Не в сети
  • Захожу иногда
  • Сообщений: 52
  • Спасибо получено: 22
  • Репутация: 1
К сожалению у меня не удаляется. Релиз тот же что и у Вас. Буду искать в модуле где же эта процедура удаления из справочника и почему она не срабатывает.
Администратор запретил публиковать записи гостям.
Спасибо сказали: Андрей Ланьшин

Начисление по среднему отпуск 2 нед. 4 дн. назад #4

  • Anat
  • Anat аватар
  • Не в сети
  • Захожу иногда
  • Сообщений: 52
  • Спасибо получено: 22
  • Репутация: 1
Нашел процедуру и нашел почему спасибо.
Администратор запретил публиковать записи гостям.
Спасибо сказали: Андрей Ланьшин

Начисление по среднему отпуск 2 нед. 4 дн. назад #5

Anat пишет:
нашел почему
И почему же, если не секрет? ;)
Администратор запретил публиковать записи гостям.
Спасибо сказали: Андрей Ланьшин

Начисление по среднему отпуск 2 нед. 4 дн. назад #6

  • Anat
  • Anat аватар
  • Не в сети
  • Захожу иногда
  • Сообщений: 52
  • Спасибо получено: 22
  • Репутация: 1
Меняли фамилию на другую в рассчитанном документе и чудным образом запись сохранялась. В процедуре визуализировал

Процедура ОбработкаУдаленияПроведения(Отказ)
УдалитьЗаписиОтпуска();
КонецПроцедуры

Процедура УдалитьЗаписиОтпуска()
л_Таблица = ТаблицаДокумента.Выгрузить();
л_Таблица.ВыбратьСтроку();
л_Таблица.Свернуть("Сотрудник");
Для Каждого л_Строка Из л_Таблица Цикл
л_Сотрудник = л_Строка.Сотрудник;
л_СотрудникОбъект = л_Сотрудник.ПолучитьОбъект();
л_МассивСтрок = л_СотрудникОбъект.Отпуска.НайтиСтроки(Новый Структура("Документ", Ссылка));
Если л_МассивСтрок.Количество() > 0 Тогда
Для Каждого л_СтрокаОтпуск Из л_МассивСтрок Цикл
л_СотрудникОбъект.Отпуска.Удалить(л_СтрокаОтпуск);
КонецЦикла;
л_СотрудникОбъект.Записать();
КонецЕсли;
ОбщегоНазначения.УдалитьСтаж(Ссылка, л_Строка.Сотрудник);
КонецЦикла;
КонецПроцедуры
затем попробовал еще раз отмену проведения все всало на место будет время еще попробую смоделировать возможно при снятии проведения справочник был открыт.
Администратор запретил публиковать записи гостям.
Спасибо сказали: Андрей Ланьшин

Начисление по среднему отпуск 2 нед. 4 дн. назад #7

  • Anat
  • Anat аватар
  • Не в сети
  • Захожу иногда
  • Сообщений: 52
  • Спасибо получено: 22
  • Репутация: 1
Видимо в проведенном документе поменяли фамилию рассчитали и провели. записи стали у двух сотрудников снимаем с проведения у второго запись снимается у первого остается. Надо предусмотреть поцедуру снятия записи при смене сотрудника в проведенном документе. Клиент может сделать такое что невозможно программистам смоделировать.
Последнее редактирование: 2 нед. 4 дн. назад от Anat.
Администратор запретил публиковать записи гостям.

Начисление по среднему отпуск 2 нед. 4 дн. назад #8

  • Anat
  • Anat аватар
  • Не в сети
  • Захожу иногда
  • Сообщений: 52
  • Спасибо получено: 22
  • Репутация: 1
Или проще не допускать смену сотрудника в проведенном документе
Администратор запретил публиковать записи гостям.
Время создания страницы: 0.130 секунд
Работает на Kunena форум