Добро пожаловать, Гость
Логин: Пароль: Запомнить меня

ТЕМА: ТУРВ и статусы работ

ТУРВ и статусы работ 7 мес. 4 дн. назад #1

  • Кузякин Максим
  • Кузякин Максим аватар
  • Не в сети
  • Захожу иногда
  • Сообщений: 75
  • Спасибо получено: 11
  • Репутация: 5
Здравствуйте. Камин 3.5.61.4.
Никак не получается сформировать Табель учета рабочего времени (и документ, и отчет) только по основным сотрудникам.
Документ ТУРВ заполняю через помощник подбора, в котором отмечено только Основное место работы. Подбираются основные и замещения со статусом Внутреннее совм. В справочнике Статусы работы несколько внутренних совместительств, а при заполнении отсекаются не все:
л_СписокСтатусов = л_Форма.СписокСтатусов.Скопировать();
Для Каждого л_ЭлементСписка Из л_СписокСтатусов Цикл
Если Не л_ЭлементСписка.Пометка Тогда
л_СписокСтатусов.Удалить(л_ЭлементСписка);
КонецЕсли;
КонецЦикла;
В отчете ТУРВ с помощником подбора только по основным выводятся все - отбора по статусу нет совсем.
Будут ли исправления?
Тема заблокирована.

ТУРВ и статусы работ 6 мес. 3 нед. назад #2

  • Irina
  • Irina аватар
  • Не в сети
  • Захожу иногда
  • Сообщений: 56
  • Спасибо получено: 65
  • Репутация: 5
Здравствуйте.
Данная ситуация не является ошибкой программы, так работает документ.
Помощник подбора производит подбор именно сотрудников по заданным параметрам, а в документе Табель УРВ заполняются все места работы по подобранным сотрудникам.
В документе Табель УРВ есть возможность установить отбор только по подразделению, заполнив его в "шапке" документа.
Вносить изменения в эту часть конфигурации не планируется.
Тымчук Ирина, фирма КАМИН
Тема заблокирована.
Спасибо сказали: Андрей Ланьшин

ТУРВ и статусы работ 6 мес. 3 нед. назад #3

  • Кузякин Максим
  • Кузякин Максим аватар
  • Не в сети
  • Захожу иногда
  • Сообщений: 75
  • Спасибо получено: 11
  • Репутация: 5
Спасибо за ответ.
В документе ТУРВ в запросе по сотрудникам есть условие
КадровыеСведения.СтатусРаботы В(&СписокСтатусов)
и всё бы работало, если бы СписокСтатусов заполнялся правильно. А заполняется он неправильно: из него удаляются не все ненужные строки:
Для Каждого л_ЭлементСписка Из л_СписокСтатусов Цикл
			Если Не л_ЭлементСписка.Пометка Тогда
				л_СписокСтатусов.Удалить(л_ЭлементСписка);
			КонецЕсли; 
		КонецЦикла; 
Так строки из списка не удаляются. Я бы сама исправила эту ошибку, но конфигурация базовая..
Тема заблокирована.
Спасибо сказали: Андрей Ланьшин

ТУРВ и статусы работ 6 мес. 3 нед. назад #4

  • Irina
  • Irina аватар
  • Не в сети
  • Захожу иногда
  • Сообщений: 56
  • Спасибо получено: 65
  • Репутация: 5
Здравствуйте.
Спасибо.
Описанная Вами ошибка будет устранена в следующем релизе.
Тымчук Ирина, фирма КАМИН
Тема заблокирована.
Спасибо сказали: Андрей Ланьшин
Время создания страницы: 0.122 секунд
Работает на Kunena форум